[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: find-versioned-module bugs

From: Andy Wingo
Subject: Re: find-versioned-module bugs
Date: Wed, 16 Jun 2010 09:23:53 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.92 (gnu/linux)

On Wed 16 Jun 2010 01:12, address@hidden (Ludovic Courtès) writes:

> Andy Wingo <address@hidden> writes:
>> In our case, my opinion is that we should change the rule to be, "the
>> first compatible version found in the path"; though perhaps we should
>> wait for confirmation from Ludovic.
> I’m a bit lost.  As you said on IRC, we should probably start by looking
> at what other implementations do (for those implementations that resolve
> modules at run-time, that is.)

Well I am a little lost too. Currently I would be fine with not encoding
version information into the path at all; the only way to support
multiple installed versions would be %load-path trickery. So instead of
rnrs/6/base.scm, just rnrs/base.scm (though the module still stores its


reply via email to

[Prev in Thread] Current Thread [Next in Thread]