[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guile 1.9.14 & GIT version linking errror

From: Neil Jerram
Subject: Re: Guile 1.9.14 & GIT version linking errror
Date: Sun, 16 Jan 2011 10:18:51 +0000
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1 (gnu/linux)

Hans Aberg <address@hidden> writes:

> On 16 Jan 2011, at 00:11, Hans Aberg wrote:
>> ... when I try to install guile-1.9.14, I get the error below (Mac
>> OS X 10.5.8 PPC G4).
>> ld: duplicate symbol ___gmpz_abs in .libs/libguile_2.0_la-arbiters.o
>> and .libs/libguile_2.0_la-alist.o
> And I get the same error when using GIT.

Well, I guess the next steps are to

- look under /usr/include to find out which header file defines
  ___gmpz_abs (probably one of GMP's)

- understand why it is being _defined_ twice, as opposed to just

- see if there is some incantation we can add to the Guile source to
  prevent the double definition.

Would you be able to have a look at that?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]