[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Assertion failure while building libtool

From: Mark H Weaver
Subject: Assertion failure while building libtool
Date: Fri, 07 Jun 2013 13:25:58 -0400

I did a clean rebuild of guix from git master (make clean; ./bootstrap;
make), and then attempted to upgrade all packages.  After several
successful builds, the daemon printed this:

guix-daemon: nix/libstore/local-store.cc:526: void 
nix::canonicalisePathMetaData_(const Path&, uid_t, nix::InodesSeen&): Assertion 
`!((((st.st_mode)) & 0170000) == (0040000))' failed.

Here are the last several lines of output from the console where I ran
the upgrade:

--8<---------------cut here---------------start------------->8---
test -z 
"/nix/store/wbsypglflcy7fi08h4finffjy9mqzh12-libtool-2.4.2/share/man/man1" || 
/nix/store/2p8di9qlp6l5z7bq5qgnpx99vl8rim2a-coreutils-8.21/bin/mkdir -p 
 /nix/store/2p8di9qlp6l5z7bq5qgnpx99vl8rim2a-coreutils-8.21/bin/install -c -m 
644 ./doc/libtool.1 ./doc/libtoolize.1 
make[3]: Leaving directory `/tmp/nix-build-libtool-2.4.2.drv-0/libtool-2.4.2'
make[2]: Leaving directory `/tmp/nix-build-libtool-2.4.2.drv-0/libtool-2.4.2'
make[1]: Leaving directory `/tmp/nix-build-libtool-2.4.2.drv-0/libtool-2.4.2'
phase `install' succeeded after 1 seconds
starting phase `patch-shebangs'
phase `patch-shebangs' succeeded after 0 seconds
starting phase `strip'
stripping binaries in 
"/nix/store/g1wl3hkiykindg7xjl05r57vim6jsyki-libtool-2.4.2-bin/bin" with flags 
 File format not recognized
 File format not recognized
stripping binaries in 
"/nix/store/wbsypglflcy7fi08h4finffjy9mqzh12-libtool-2.4.2/lib" with flags 
File format not recognized
phase `strip' succeeded after 0 seconds
In ice-9/boot-9.scm:
 157: 13 [catch #t #<catch-closure 1cbb4c0> ...]
In unknown file:
   ?: 12 [apply-smob/1 #<catch-closure 1cbb4c0>]
In ice-9/boot-9.scm:
  63: 11 [call-with-prompt prompt0 ...]
In ice-9/eval.scm:
 432: 10 [eval # #]
In ice-9/boot-9.scm:
2320: 9 [save-module-excursion #<procedure 1cebcc0 at ice-9/boot-9.scm:3961:3 
3966: 8 [#<procedure 1cebcc0 at ice-9/boot-9.scm:3961:3 ()>]
In unknown file:
   ?: 7 [load-compiled/vm 
In guix/ui.scm:
 462: 6 [run-guix-command package "--upgrade"]
In ice-9/boot-9.scm:
 157: 5 [catch srfi-34 #<procedure 2821d20 at guix/ui.scm:148:2 ()> ...]
In guix/scripts/package.scm:
 929: 4 [#<procedure 2825f30 at guix/scripts/package.scm:915:8 ()>]
 824: 3 [process-actions (# # # #)]
In guix/store.scm:
 474: 2 [build-derivations # #]
 325: 1 [process-stderr #]
In guix/serialization.scm:
  49: 0 [read-int #<input-output: socket 5>]

guix/serialization.scm:49:4: In procedure read-int:
guix/serialization.scm:49:4: In procedure bv-u32-ref: Wrong type argument in 
position 1 (expecting bytevector): #<eof>
--8<---------------cut here---------------end--------------->8---

This is current git master (v0.2-82-gb2e3dd9) running on Debian Wheezy
with Guile 2.0.9.  I ran the daemon with the command:

 ./pre-inst-env guix-daemon --no-substitutes --build-users-group=guix-builder

The upgrade command was: ./pre-inst-env guix package --upgrade

Any idea what went wrong here?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]