[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-gv] Re: Bug#583316: /usr/bin/gv: Insecure gs workaround "gs -P-"

From: Markus Steinborn
Subject: [bug-gv] Re: Bug#583316: /usr/bin/gv: Insecure gs workaround "gs -P-"
Date: Sat, 29 May 2010 12:47:57 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; de; rv: Gecko/20100317 SeaMonkey/2.0.4

address@hidden schrieb:
Yes that is what I do:

#!/usr/bin/perl --
$c = $0;
$c =~ s/.*\///;
exec "/usr/bin/$c", '-P-', '-dSAFER', @ARGV;

and my testing suggested it breaks gv.
Well, the DSC parsing seems to be "-dSAFER"-incompatible. But with the following settings I can open ps and pdf files - and pdf to postscript conversion has sucessfully been tested on an example.

$ cat .gv
GV.gsArguments:         -P- -dFIXEDMEDIA
GV.antialias:           False
GV.infoVerbose:         All
GV.gsInterpreter:       gs
!GV.saveposFilename:    ~/test.gv
GV*international:               False
GV.version:             gv

GV.gsCmdConvPDF: gs -P- -dSAFER -dNOPAUSE -dQUIET -dBATCH -sDEVICE=pswrite -sOutputFile=%s -f %s -c save pop quit GV.gsCmdScanPDF: gs -P- -dNODISPLAY -dQUIET -sPDFname=%s -sDSCname=%s %s pdf2dsc.ps -c quit

So "-P-" may work with GNU gv - but some testing would help before changing the defaults.

BTW: I have done my test with ghostscript 8.71.

Greetings from Germany

Markus Steinborn
GNU gv maintainer

reply via email to

[Prev in Thread] Current Thread [Next in Thread]