bug-hurd
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS help needed, top and htop


From: Samuel Thibault
Subject: Re: CVS help needed, top and htop
Date: Fri, 15 Aug 2008 10:45:15 +0100
User-agent: Mutt/1.5.12-2006-07-14

address@hidden, le Fri 15 Aug 2008 02:26:29 +0200, a écrit :
> > 2. In the file proc/version.c, the procps determines the version of
> > Linux kernel to which the /proc belongs to and as I suppose it changes
> > the way it reads the fields from /proc files vary. But on Hurd this
> > version is returned as 0.3.0 which is in no way valid for procps. As
> > of now I have Hard Coded it to 2.6.18, since the procfs I have written
> > in most compatible with that version of Linux. So how do you suggest I
> > patch it? Atleast here we need to differentiate between Hurd's version
> > of procps and Linux's version of procps. How do I do it?
> 
> I don't understand. What is the problem if you just have procfs return
> 2.6.18?

The problem is that he didn't notice that there was a debian kfreebsd
patch that makes procps use the value from /proc.  The original code use
uname.

Samuel




reply via email to

[Prev in Thread] Current Thread [Next in Thread]