bug-hurd
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gnumach FTBFS


From: Thomas Schwinge
Subject: Re: gnumach FTBFS
Date: Wed, 18 May 2011 12:18:39 +0200
User-agent: Notmuch/0.5-77-g335dd52 (http://notmuchmail.org) Emacs/23.2.1 (i486-pc-linux-gnu)

Hallo!

On Wed, 18 May 2011 11:37:45 +0200, Svante Signell <address@hidden> wrote:
> On Wed, 2011-05-18 at 10:31 +0200, Samuel Thibault wrote:
> > Samuel Thibault, le Wed 18 May 2011 10:28:50 +0200, a écrit :
> > > Svante Signell, le Sun 15 May 2011 11:11:41 +0200, a écrit :
> > > > On Sun, 2011-05-15 at 00:26 +0200, Samuel Thibault wrote:
> > > > > > I run Hurd under qemu on a Debian GNU/Linux testing box. qemu-kvm
> > > > > > version 0.14.0+dfsg-1~tls
> > > > > 
> > > > > Which precise version of gcc are you using?
> > > > 
> > > > gcc --version
> > > > gcc-4.6.real (Debian 4.6.0-6) 4.6.1 20110428 (prerelease)
> 
> Now I use:
> gcc-4.6.real (Debian 4.6.0-7) 4.6.1 20110507 (prerelease)
> same results as before.

Wait a moment...  gcc-4.6.real.  Is that still with the hardening-wrapper
package installed?  -- OK...  I should just continue reading your
email...  :-)

> > With which CFLAGS does the build happen? Is it simply dpkg-buildpackage?
> 
> dpkg-buildpackage -b
> CFLAGS seems to be:     -Wall -g -pipe -fno-strict-aliasing -O2
> from debian/rules and: -nostdinc -imacros -fno-stack-protector
> from build/Makefile
> 
> However the hardening wrapper is active around gcc-4.6. I don't think it
> is active though, it has to be activated in the debian/rules file.

Might still be some odditiy with the wrapper.  Please un-install that one
(or force the GNU Mach build to use /usr/bin/gcc-4.6.real (by setting
CC?)), and try again.  If that resolves the problem, we got another
candidate that needs debugging with respect to the hardening wrapper.


Grüße,
 Thomas

Attachment: pgpgMYfUC1ERT.pgp
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]