bug-hurd
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Gnumach [user_level_drivers] FTBFS -- -lpthread-stubs


From: Stephen Gilles
Subject: Gnumach [user_level_drivers] FTBFS -- -lpthread-stubs
Date: Mon, 27 Feb 2012 13:32:09 -0500
User-agent: Mutt/1.5.21 (2010-09-15)

Hello,

I decided this morning to try and build an updated version of gnumach
from the user_level_drivers branch, and I have been unable to proceed,
as /bin/ld cannot find -lpthread-stubs.  grep -HiR has been unable to 
show me where pthread-stubs is referred to in the source directory, and
tschwinge on #hurd has confirmed that pthreads should not be used at all
in gnumach.

So to make a long story short, I cannot build gnumach from source, and I
am confused as to why.  I have attached an extensive log leading up to
the error, as well as the build script I am using.  The OS is Arch Hurd,
and I am compiling natively.

This is probably user error, but I would appreciate anyone pointing out
what I am doing wrong.

Thanks,
Gilles

Attachment: output.log
Description: Text document

Attachment: PKGBUILD
Description: Text document

Attachment: pgpuzYA8u0OUs.pgp
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]