bug-hurd
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Fix compilation error with older versions of gcc


From: Thomas Schwinge
Subject: Re: [PATCH] Fix compilation error with older versions of gcc
Date: Mon, 19 Nov 2012 16:37:46 +0100
User-agent: Notmuch/0.9-101-g81dad07 (http://notmuchmail.org) Emacs/23.3.1 (i486-pc-linux-gnu)

Hi!

Welcome Matthew to GNU Hurd development!  :-)


On Mon, 19 Nov 2012 15:02:52 +0000, Matthew Leach <address@hidden> wrote:
> Some versions of gcc will error if you define a type twice (even if
> the definition is the same). The ncr53c8xx scsi driver defines
> 'vm_offset_t', this is also defined in mach_types.h and will therefore
> cause a compilation error depending on the gcc version.
> 
> * linux/src/drivers/scsi/ncr53c8xx.c: exclude the typedef's if we are
>   executing a mach build.

(We already discussed this issue/patch on IRC.)  Thanks for the patch,
pushed as commit bdae52f1465743ad96b2261e053ae4967f807557 with the
following slightly modified commit message (GNU ChangeLog style takes
some time to master, no worries):

    Fix compilation error with older versions of GCC
    
    Some versions of GCC will error if you define a type twice (even if
    the definition is the same). The NCR53C8XX SCSI driver defines
    'vm_offset_t', this is also defined in vm_types.h and will therefore
    cause a compilation error depending on the GCC version.
    
    * linux/src/drivers/scsi/ncr53c8xx.c [!MACH] (vm_offset_t, vm_size_t): Don't
    define types.


Grüße,
 Thomas

Attachment: pgpEPZf5ccLW7.pgp
Description: PGP signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]