[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


From: Simon Bazley
Subject: telnetd-sys_term.c
Date: Thu, 20 Sep 2001 18:30:54 +0100

Hi there,
        I may be doing something wrong, so I have my asbestos jacket on (feel 
free to flame me).  

        I can happily compile all the inetutils apps except telnetd.  

        In the telnetd directory all files compile, except sys_term.c which 
bombs.  I have the response from gcc and the result from cpp if you want them.  
The problem seems to come down to the utmp struct, which is never defined 
according to the result from
cpp.  utmpx is defined but like I say not utmp, so it complains appropriately 
as soon as struct utmp is used.  

        I've tried this with 1.3.2 1.3a and 1.3b the same error arrises each 
time.  Once I remove telnetd (replace it with libtelnet so it appears to be 
there) the whole package (inetutils) builds fine.  

        I thought it a good idea to check the existence of utmp. this is what I 

kenny:/# find -name utmp*

        I'm using debian 2.2r3, but the debian bits are minimal, as I'm trying 
to build everything myself, rather than using .deb files.  

        Any ideas?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]