[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

libtool overquoting?

From: Rob Browning
Subject: libtool overquoting?
Date: Tue, 11 Sep 2001 20:58:33 -0500
User-agent: Gnus/5.090004 (Oort Gnus v0.04) Emacs/20.7

With libtool 1.4.1, I've been having trouble running programs because
libtool seems to be "overquoting".  The simplest example is this:

  $ libtool --mode=execute echo foo

While this isn't itself a problem, when you try to do something like:

  $ run-guile 1.5

where run-guile is a shell script that sets some environment variables
(like PATH, GUILE_LOAD_PATH, etc.) based on the argument (in this
case, the 1.5), and then exec's guile, guile fails because somewhere
along the way libtool is adding an extra level of quoting to the 1.5.
i.e. guile ends up trying to load from a path like:


which, of course, doesn't exist.

I wasn't completely sure this was a bug, but I didn't see anything
similar in the past few months of the bug list, so I thought it worth


Rob Browning
rlb @defaultvalue.org, @linuxdevel.com, and @debian.org
Previously @cs.utexas.edu
GPG=1C58 8B2C FB5E 3F64 EA5C  64AE 78FE E5FE F0CB A0AD

reply via email to

[Prev in Thread] Current Thread [Next in Thread]