[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [libtool 2.1a] testsuite: 25 26 un-"expected failure" onhppa2.0w-hpu

From: Ralf Wildenhues
Subject: Re: [libtool 2.1a] testsuite: 25 26 un-"expected failure" onhppa2.0w-hpux11.11
Date: Mon, 15 Oct 2007 19:10:45 +0200
User-agent: Mutt/1.5.16 (2007-10-11)

Hello Michael,

* Michael Haubenwallner wrote on Mon, Oct 15, 2007 at 03:52:04PM CEST:
> On Fri, 2007-10-12 at 18:20 +0200, Ralf Wildenhues wrote:
> > 
> > is "no", it doesn't currently work.  fast_install is no on HP-UX/PA
> > because we don't use nodefaultrpath, IIRC, only on ia64.  And IIRC there
> > was a conscious decision not to do so on PA, but offhand don't remember
> > why.  Libtool 1.5.x should be similar here.
> Hmm - this means one cannot do DESTDIR installs on hppa-hpux using
> libtool at all yet ?

Yes, that is correct.

> > > Thing is, testsuite 25 and 26 result to "expected failure", which really
> > > should be "FAIL".
> > 
> > I'm not sure why you think that.  The testsuite matches the expected
> > behavior of the code, just maybe not the desired one.  That's what
> > "expected failure"s mean.
> This was because I could not believe that broken DESTDIR install is
> intentionally, as this is a basic prerequisite for package managers IMO
> to work properly.
> Anyway - are there any plans (or patches already) to get this work ?

I would sure love to have this work on more systems.
For example, HEAD has this fixed for OpenBSD, while 1.5.x has not.

As to HP-UX/PA, if someone could do the research and testing, that would
be great.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]