[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cannot avoid libtool producing static library and la file for a plug

From: Stefan Kost
Subject: Re: Cannot avoid libtool producing static library and la file for a plugin
Date: Mon, 08 Sep 2008 22:26:45 +0300
User-agent: Thunderbird (X11/20071114)

Stefan Kost schrieb:
Ralf Wildenhues schrieb:

Hello Stefan,

* Stefan Kost wrote on Wed, Sep 03, 2008 at 04:29:23PM CEST:
I've installed 2.2.4. no idea why all my distributions still stick to
1.5.26. I've installed libtool to /usr/local and bootstapped with
ACLOCAL_FLAGS="-I /usr/local/share/aclocal" ./autoregen.sh
Build works, but *.la and *.a files are still installed. Please let me
know, if there is something else I could try.
FWIW, the *_LIBTOOLFLAGS requires Automake 1.10 or newer to work (but it
works already with Libtool 1.5.x).  With this flag it will not install
the static library.  It will still install the .la file, of course.
There is little point in caring about that small file, with a plugin.

it worked \o/. Thanks a lot.

Btw. is it really neccesary to run libtool --finish for plugins. This calls

"ldconfig -n /path/to/plugins" and print a lot of text that suggest users to 
eventually add the libdir to their LD_LIBRARY_PATH, which is definitely no what they 
should do.

I interpret that silence that right now there is no means for appropriate $finish_cmds for shared libraries build as modules. Is this something that could be added? Is there any supported platform that needs to run something in this step?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]