[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libtool-2.2.6a breaks build of guile-1.8.5, libtool-1.5.26 is OK

From: Ralf Wildenhues
Subject: Re: libtool-2.2.6a breaks build of guile-1.8.5, libtool-1.5.26 is OK
Date: Tue, 4 Nov 2008 22:35:57 +0100
User-agent: Mutt/1.5.18 (2008-05-17)

Hello Sergei,

* Sergei Steshenko wrote on Tue, Nov 04, 2008 at 12:33:54PM CET:
> for many months I've been building various versions 'guile' using various
> versions of 'libtool', and while libtool was in its 1.5.* versions the
> builds were OK, but from version 2.* or so the builds fail, so I'm forced
> to use libtool-1.5.26.

Thanks for the report.  I wonder a bit though why you haven't done this
earlier; if this were a Libtool bug in all 2.x versions, that would have
been quite a problem for us, and very much worthy of fixing.

> Now, the failure - on can see it at the end of the attached
> 'make.libtool-2.2.6a.log.gz' file.

It looks like you are using a ltdl.h file from 1.5.x together with a
libltdl.la from 2.2.x.

Whatever it is exactly, I'm pretty sure it's not a Libtool problem,
but some kind of impedance mismatch on your side.  I'd be willing to
help debug it, but for that I'd prefer you put up a tarball somewhere
that exposes the problem.

FWIW, I've just successfully finished building guile 1.8.3 using Libtool
(and libltdl) from 2.2.6a.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]