[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

can't build graphviz; version conflicts with latest libtool

From: Stephen North
Subject: can't build graphviz; version conflicts with latest libtool
Date: Tue, 27 Jan 2009 17:29:53 -0500

Greetings. Apologies if this is the wrong place. In recent libtool (2.2.6
as installed in Ubuntu 8.10 or Macports updates, for instance) I can't
build graphviz from scratch. The build dies with an error:
scn<25> make
make  all-recursive
make[1]: Entering directory `/home/north/src/graphviz2'
Making all in libltdl
make[2]: Entering directory `/home/north/src/graphviz2/libltdl'
make  all-am
make[3]: Entering directory `/home/north/src/graphviz2/libltdl'
/bin/bash ./libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H - I. -g -O2 -c -o ltdl.lo ltdl.c
./libtool: line 463: CDPATH: command not found
./libtool: line 1141: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.6, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6
libtool: and run autoconf again.
make[3]: *** [ltdl.lo] Error 63
make[3]: Leaving directory `/home/north/src/graphviz2/libltdl'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/north/src/graphviz2/libltdl'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/north/src/graphviz2'
make: *** [all] Error 2

Is this something that you know about already?  I'm at a loss.

Stephen North

reply via email to

[Prev in Thread] Current Thread [Next in Thread]