[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libtool-2.2.11a on AIX 5.3 / 5.3 current git master - tests/mdemo-in

From: Ralf Wildenhues
Subject: Re: libtool-2.2.11a on AIX 5.3 / 5.3 current git master - tests/mdemo-inst.test 2./3. occurrence
Date: Wed, 4 Aug 2010 21:37:48 +0200
User-agent: Mutt/1.5.20 (2010-04-22)

* Rainer Tammer wrote on Wed, Aug 04, 2010 at 09:13:03PM CEST:
> I might have a solution to the shared library problem.
> If foo1.so is ro to others then the libary is loaded into a private segment.
> This would avoid the problem. The library is then unloaded as soon as the
> program which uses the library is unloaded.

Yes.  In the setup of the new testsuite, we use this to work around it:

  # On AIX, shared libraries remain loaded in memory after use if they
  # are world-readable, until root issues slibclean.  On NFS, this causes
  # a testsuite rerun to fail to clean up test group directories.  Avoid
  # this with a suitable umask.  Do not do this on other systems, for
  # example HP-UX suffers unless shared libraries are mode 555.
  case $host_os in
  aix*) umask o-rwx ;;

> Would this change pose a problem on other platforms ?

Yes, it would; see the comment above.

How come though this didn't show up for you with older Libtool versions?
We've had these tests for a long time.  Can the directory be 'rm -rf'ed
(assming you have build tree separate from source tree) or the output
file .libs/foo1.so renamed while in use?

Have you changed your setup?  For example, I do all AIX tests on NFS
mounts, where the new testsuite used to output spurious errors trying to
`rm -rf' the old test group directories due to the unremovable stale NFS


reply via email to

[Prev in Thread] Current Thread [Next in Thread]