[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compilation error in 1.5.66

From: Mats Bengtsson
Subject: Re: Compilation error in 1.5.66
Date: Tue, 09 Jul 2002 15:13:53 +0200

> > I searched the Debian package database and there is no
> > sstream file in any of the packages for Debian stable, 
> > only in testing/unstable. I use the libstdc++2.10-dev
> > version  1:2.95.2-13 from current Debian stable, which 
> > doesn't contain sstream.
> Ok, thanks.  So we should probably check for that header.
> > Well, I certainly don't want to go inte the hazzle of mixing my 
> > stable Debian with lib files from unstable (libstdc++2.10-dev 
> > 1:2.95.4-7 from unstable requires a newer libc6 and newer compiler).
> Are you planning to (immediately) upgrade to woody, when it becomes
> stable?  That should be any day now.

Probably not the first day of the release but reasonably soon.
Yet, we shouldn't expect all our users to be on the bleeding
edge of development.

> You could try what happens if you use the strstream header, but I
> suspect there will be other problems.  People are posting bug reports
> for gcc 3.x more regularly now, so I think we should support that in
> 1.6.

Of course, but it doesn't mean we should abandon the support
for older versions immediately. So far, it only involves a 
single file. I simply copied source-file.cc from an older Lilypond
and it seems to work well.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]