[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: font map problem solved BUT another bug found in lilypond book 2.5.1

From: Bernard Hurley
Subject: Re: font map problem solved BUT another bug found in lilypond book 2.5.19
Date: Thu, 14 Apr 2005 14:25:25 +0100

On Thu, 2005-04-14 at 14:24 +0200, Mats Bengtsson wrote:
> Bernard Hurley wrote:
> > On Thu, 2005-04-14 at 12:52 +0200, Mats Bengtsson wrote:
> > 
> >>Did you read what the LilyPond manual says about flags to the
> >>dvips command? See
> >>http://lilypond.org/doc/v2.5/Documentation/user/out-www/lilypond/Integrating-LaTeX-and-music.html#Integrating-LaTeX-and-music
> >>
> >>
> >>    /Mats
> >>
> > 
> > 
> > Yes that's how I originally called dvips but the map files lilypond.map
> > and ec-mftrace.map don't reference CenturySchL-Ital or CenturySchL-Roma
> > both of which found their way into  lily-333498224-1.eps. I don't know
> > which of these files _should_ reference these fonts, but download35.map
> > _does_ and adding it to the list of map files solves the problem.
> None of them! The question is if it really was a problem. At least on
> my system, the result file works perfectly well even though I get the
> warning. These fonts should be available in any standard PostScript
> interpreter, so there's no need to embed them into the file. As far
> as I can understand, dvips doesn't realize this fact when the font
> is used in an included .eps file (I've seen the same phenomenon when
> including graphics files in LaTeX documents in completely different
> contexts). So, my conclusion is that the error message is harmless.

I think it is probably my set-up that is to blame! I have a Debian
system with Lily 2.4 on it. I wanted to try 2.5 without doing anything
to my "global" settings for tetex and lily, so I created a new user and
installed lily 2.5 and gs 8.15 locally for this user - I don't ususally
upgrade anything for the whole system until there is a Debian package
for it. If I take out the reference to download35.map, (the local) gs
crashes when I try to view the score, so it obviously isn't finding the
fonts. I don't know it that is because it has been installed "locally"
or not.

> Another reason I refered to the manual is that there's no need to
> use a full path to the map files (at least if you have a correct
> installation of teTeX and LilyPond), since dvips will find them
> through its file name database.

Aha! I now realise that it is only lilypond.map for which I need the
full path name. Presumably without it dvips finds the wrong one (i.e.
the one for version 2.4)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]