[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 2.6.3 midi2ly: bad midi module location

From: Graham Percival
Subject: Re: 2.6.3 midi2ly: bad midi module location
Date: Wed, 24 Aug 2005 19:13:36 -0700

Thanks for this info!  The problem (and solution) appears on
OSX 10.3.9 as well.

Developers, can we modify  scripts/midi2ly.py  accordingly?

- Graham

On 18-Aug-05, at 7:21 AM, John Mandereau wrote:

When I tried to run 2.6.3 midi2ly on Fedora Core 4, I got:

Traceback (most recent call last):
  File "/usr/bin/midi2ly", line 42, in ?
    import midi
ImportError: No module named midi

I fixed it:
I opened midi2ly.py and edited these lines:

libdir = '/usr/lib/lilypond/2.6.3'
if not os.path.isdir (libdir):
       libdir = '/usr/lib/lilypond/2.6.3'
sys.path.insert (0, os.path.join (libdir, 'python'))

I replaced 'lib' with 'share' and saved the file, then it worked!

This bug may also happen on other platforms (it happens with Windows
native version, but it won't work anyway, because there is no midi lib)
John Mandereau <address@hidden>

bug-lilypond mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]