[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Missing accented letters in header using lilypond-book

From: Mats Bengtsson
Subject: Re: Missing accented letters in header using lilypond-book
Date: Wed, 22 Feb 2006 10:59:15 +0100
User-agent: Internet Messaging Program (IMP) H3 (4.0.4)

I don't agree fully with Erik's comment. What happens is that the
embedded LilyPond code should be saved with UTF-8 encoding, whereas
the rest of the LaTeX code should be saved with latin1 encoding.
Since there probably isn't any text editor that supports saving a file
with different character encodings for different sections of the same
file, it's probably easiest to write the LilyPond code in separate
files and use \lilypondfile{} in the LaTeX document. Then you can
easily use different character encodings for the main document and the
LilyPond code.


Quoting René Brandenburger <address@hidden>:

hmm, using te LaTeX code results in the printed out LaTeX code with ij
still missing :-(
I tried without the accented character (setting title = "'T as Freijor",
and still the ij is missing in the output as shown in the attached
image. Didn't try the UTF-8 version yet.

On Tue, 2006-02-21 at 12:14 +0100, Erik Sandberg wrote:
On Monday 20 February 2006 18.39, René Brandenburger wrote:
> Hi,
> i have a little score with the word "Fréijor" in the header field.
> Running it through lilipond just works fine, but running it through
> lilypond-book and postprocessing with latex, dvips and ps2pdf, in the
> resulting pdf the header shown is actually "Fré or" as shown in the
> attached file. The lyrics are ok.

I think you need to either use the LaTeX code for é, "\`e", or use the UTF-8
capable version of latex (look for latex-ucs). Both suggestions are untested

reply via email to

[Prev in Thread] Current Thread [Next in Thread]