[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: \tempo and Span_dynamic_performer errors in 2.10.20 on WinXP

From: Mats Bengtsson
Subject: Re: \tempo and Span_dynamic_performer errors in 2.10.20 on WinXP
Date: Mon, 05 Mar 2007 08:47:47 +0100
User-agent: Thunderbird (X11/20061206)

You apparently have a file written for an older version of LilyPond
and haven't updated the file syntax to correspond to your current version.
Hopefully, the original author of the file (you?) has remembered to include
a \version ... command in the file. In that case, it's just to run convert-ly on the
file to update the syntax, see
for detailed instructions for Windows.

If there isn't any \version statement in the file, you have to figure out
which version the file was written for. Let's say that it was written for
version 2.4. In that case, just specify this information in an additional
flag to the convert-ly command:
convert-ly --from="2.4.0" -e myfile.ly


Nikhil wrote:

I installed LilyPond on WinXP (SP2) and tried it with "blue_danube.ly" to get this error message:

-----[ start of error dump ]-----

# -*-compilation-*-
Changing working directory to `/sheets'
Processing `/sheets/blue_danube_new.ly'
/sheets/blue_danube_new.ly:344:19: error: syntax error, unexpected \tempo \midi { \tempo 4=150

error: unknown translator: `Span_dynamic_performer'

-----[ end of error dump ]-----

I'm unable to attach the file using thise gmane.org post form, so here is the link:

What might the issue be?


bug-lilypond mailing list

        Mats Bengtsson
        Signal Processing
        Signals, Sensors and Systems
        Royal Institute of Technology
        SE-100 44  STOCKHOLM
        Phone: (+46) 8 790 8463                         
       Fax:   (+46) 8 790 7260
        Email: address@hidden
        WWW: http://www.s3.kth.se/~mabe

reply via email to

[Prev in Thread] Current Thread [Next in Thread]