[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: font error in 2.11.36 - workaround

From: Risto Vääräniemi
Subject: Re: font error in 2.11.36 - workaround
Date: Mon, 17 Dec 2007 08:46:30 -0800 (PST)

Dear All,

Risto Vääräniemi wrote:
> It also seems to affect other text features such as lyrics and markup
> (in Win2k).

I made some more tests. On my XP box the effect was similar to Martial-3's
observations, i.e., dynamic texts and time signature were converted to
sans-serif font but lyrics and markups were fine. I was wondering why I got
different results on this computer but I finally remembered that I had
copied the Lilypond OTF fonts to the Windoze Fonts directory. When did the
same trick on my W2k box I got similar results.

Somehow it seems that .36 does not find the fonts in its own directory
structure and cannot use the Feta font from Windows\Fonts directory.

When I ran LP using -V option on .35 and .36 one line caught my eye. LP .36
tries to set:
GS_FONTPATH=C:/Program Files/LilyPond/usr/bin/../share/gs/fonts

The above-mentioned directory does not exist. I tried to copy the fonts
there but nothing really changed. :-(

When printing to PS file started, .35 output a list of fonts that reside in
LP installation path. .36, however, gave a list of fonts in C:\Windows\Fonts
directory. The feta-alphabet20.pfa font was not found and was replaced by
Verdana.ttf, which caused the font weirdness.

After that I copied the Type1 Feta fonts to windoze\fonts directory (normal
copy & paste doesn't work, but command line copy does). After that LP was
able to find the Feta font and the output seemed quite OK.

This is probably not the ultimate solution but now I can use the .36.
Hopefully it is of some help.

View this message in context: 
Sent from the Gnu - Lilypond - Bugs mailing list archive at Nabble.com.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]