[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SeparationItem #'padding not working anymore?

From: Trevor Daniels
Subject: Re: SeparationItem #'padding not working anymore?
Date: Sun, 1 Mar 2009 15:38:54 -0000

Mats Bengtsson wrote Sunday, March 01, 2009 8:17 AM

Quoting Patrick McCarty <address@hidden>:

On Sat, Feb 28, 2009 at 6:00 AM, Valentin Villenave
<address@hidden> wrote:
2009/2/2 Joe Neeman <address@hidden>:
On Fri, 2009-01-30 at 12:21 -0600, Jonathan Kulp wrote:
Ok Graham. I've been trying for 20 minutes and can't figure how to use PaperColumn to change spacing, though. Joe, could you send me a snippet
that shows how to use this?

This is very embarrassing, I'm just testing the fix:

set_column_rods (cols, 0.1); // FIXME: padding

Greetings Joe,

where are we now? Does this SeparationItem thingy deserve an issue in
the tracker?

I don't think it deserves an issue.

We have two options:

1) Remove SeparationItem from LilyPond's source
(scm/define-grobs.scm).  Then we would need a convert-ly rule.
2) Keep SeparationItem, even though it is never used.

I guess it all depends on whether SeparationItem will ever be used
again in the future.

The main thing is that the documentation is modified to show a solution that works, i.e. that gives the same result as you previously could obtain setting SeparationItem #'padding = ...

Yes, we're waiting for Joe to complete his fix so we can use
'spacing-spanner in the docs.  At present no one has found a
way to make it work.  Or has this been fixed silently?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]