[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Incorrect point-and-click URIs of files with non-ASCII content on Wi

From: Patrick McCarty
Subject: Re: Incorrect point-and-click URIs of files with non-ASCII content on Windows
Date: Tue, 27 Oct 2009 00:46:47 -0700
User-agent: Mutt/1.5.20 (2009-06-14)

On 2009-10-27, Harmath Dénes wrote:
> This bug is only reproducible under Windows.

Okay, I see that now.  Sorry for the initial misunderstanding.

> (It is also important that you set the file encoding to UTF-8, but
> that is satisfied here.)


> The positions in the URL are 3:11:11, both with 2.12.2 and 2.13.6
> (sorry, I couldn't test latest git).

Thanks, I reproduced this in Wine.  On GNU/Linux (2.13.6) the output
is 3:10:10, and on Windows, the output is 3:11:11.

> The output 3:11:10 would be wierd, since the the second and third
> field only differ on tab width, and this file doesn't contain any
> tabs.

This is the output of current git on GNU/Linux.  I'm very curious to
see what the output is on Windows, but that will have to wait until

> Apparently, this is the same issue as
> http://article.gmane.org/gmane.comp.gnu.lilypond.bugs/16041 - so not
> just the point-and-click URIs, but also the problem markers are
> broken.

This is the same issue that I pushed a (hopeful) fix for:


By counting multibyte characters as "multiple characters", the error
output is fixed for ISO-88591 and UTF-8 encodings (AFAICS) on

All of that being said, I'm still not sure what the problem is with
the URIs on Windows.

Valentin, can you add this to the tracker?  The subject of this thread
is okay for an issue summary.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]