[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Multi-line titles lose text in 2.13.10

From: Patrick McCarty
Subject: Re: Multi-line titles lose text in 2.13.10
Date: Thu, 31 Dec 2009 12:07:03 -0800

On Thu, Dec 31, 2009 at 7:57 AM, Trevor Daniels <address@hidden> wrote:
> Under Windows on my system a long title or subtitle
> with the text split over two lines results in incorrect
> output or a warning.
> With 2.13.10 only the text on the first line is displayed.
> With 2.13.9 and 2.13.8 all the text is displayed but a
> warning is issued:
>> Processing `C:/Users/Trevor/Welcome_to_LilyPond.ly'
>> Parsing...
>> Interpreting music...
>> Preprocessing graphical objects...
>> programming error: FT_Get_Glyph_Name () error: invalid argument
>> continuing, cross fingers
>> programming error: Glyph has no name, but font supports glyph naming.
>> Skipping glyph U+1000000D, file C:/Program
>> Files/LilyPond/usr/share/lilypond/current/fonts/otf/CenturySchL-Bold.otf
>> continuing, cross fingers
>> Solving 1 page-breaking chunks...[1: 1 pages]
> Could someone else check this out, as it may be due
> to some problem with the fonts on my system.  It works
> fine under ubuntu running in VirtualBox.

Hi Trevor,

This warning appears to be a problem introduced (by me) when mbrtowc()
was removed.  This happened before 2.13.8.  The problem disappears
when the CR/LF line endings are changed to LF.

Once I figure out why CR/LF line endings in markup are handled
incorrectly, I'll push a fix.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]