[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: --lock-flags now configurable, and some mu_argp reorg

From: Sam Roberts
Subject: Re: --lock-flags now configurable, and some mu_argp reorg
Date: Sun, 14 Apr 2002 21:12:44 -0400
User-agent: Mutt/1.3.16i

Ok, 3 is where we are at again.


Quoteing address@hidden, on Thu, Apr 11, 2002 at 01:39:15PM +0300:
> >   I can add back the .mu. prefix for config files if thats not
> >   sufficient, but I really like the directory of config files, an
> >   idea I shamelessly stole from mutt.
> I've commented it in my previous posting. I think it's time we came to
> an agreement about the file-naming scheme:
> 1. The directory for config files is quite OK. I like the idea, too.
> 2. Naming utility-specific configs in "~/.<utility>rc" fashion would
>    be quite OK, but it breaks mail functionality.
> To restore broken mail functionality, there are three possible ways:
> 1. Rename its mailutils-specific config file to something else.
>    Drawback: This will produce an inconsitency in the naming scheme.
>    Besides, corresponging code in mu_argp.c will look quite kludgy.
> 2. Do not use mailutils-specific config for this utility at all.
>    Seems quite OK, since it has its own traditional configuration
>    file. 
>    Drawback: Inconsistency again. Besides, neither --mail-spool
>    nor --lock-flags are covered by the traditional ~/.mailrc
> 3. Use another naming scheme for config files.
> (Of course, I do not consider dropping the traditional ~/.mailrc
> functionality, it will be worse than anything)
> Personally, I'd vote for number 3. The format of our configs is
> mailutils-specific so keeping their names mailutils-specific seems
> quite logical. Again, there may be someone who has good reasons for
> using both mailutils and some other mail software, and it'd be
> a good thing if the configuration files won't collide.

Sam Roberts <address@hidden> (Vivez sans temps mort!)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]