[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug-mailutils] Bug: Error parsing parameter value containing '.' in Con

From: Christopher LaRosa
Subject: [bug-mailutils] Bug: Error parsing parameter value containing '.' in Content-type
Date: Wed, 07 Jul 2010 16:36:28 -0400

I have a message with the following valid Content-type header line:

Content-Type: multipart/Voice-Message; Version=2.0; 

The "_mime_get_param()" function in "mime.c" does not correctly parse the 
"Version=2.0" parameter in the message, even though this is a valid parameter 
according to RFC 2045 section 5.1. It stops parsing at the "." character, which 
it incorrectly treats as a special character (_ISSPECIAL).  According to RFC 
2045 section 5.1, the "." character is a valid token character as it is not 
part of "tspecials".

I found this because the "mu_message_get_num_parts()" function returns EINVAL 
for this message.  It never finds the required "boundary" parameter which 
appears later on the line, and assumes the Content-type field is invalid.

I also submitted this as Bug #30383 at "http://savannah.gnu.org/bugs";, but I am 
unsure which bug process you are currently using.

Thank you for your time.  Have a great day!

Christopher LaRosa
BlueTie, Inc.

This message is intended solely for the individual(s) to whom 
it is addressed. If you are not the intended recipient, any 
dissemination or copying is strictly prohibited. If you 
believe you received this message in error, please notify 
the sender and delete from your system. Thank you.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]