[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

strange problem with 'echo' target

From: Stefan Seefeld
Subject: strange problem with 'echo' target
Date: Fri, 15 Dec 2000 16:59:08 -0500


I'm experiencing a strange problem with make, which I can't
narrow down. What happens is that I have an 'echo' executable
in the local directory, which gets executed whenever I call
'make echo'. The make debugging output looks so:

Finished prerequisites of target file `echo.o'.
`/data1/seefelds/projects/berlin/Berlin/src/Prague/Examples/Network/echo.cc' is 
than target `echo.o'.
  Must remake target `echo.o'.
hello world
Got a SIGCHLD; 1 unreaped children.
Reaping losing child 0x08077590 PID 25653 
make: *** [echo.o] Error 255
Removing child 0x08077590 PID 25653  from chain.

where the 'hello world' line is the actual output from my 'echo' script (which 
I created for
the purpose of this test. Note that I don't have any 'echo' target in my 
Makefile. However, I
have this:

all:            $(TARGETS)

%.o:            $(srcdir)/%.cc
                @echo compiling $(@F)
                $(CXX) $(CPPFLAGS) $(CXXFLAGS) -c $< -o $@

What is going on here ?

Thanks a lot,   Stefan

PS: in fact, the problem I'm struggling with is that in my real case, I do have 
an 'echo'
    target (echo.cc -> echo.o -> echo), and the make process simply hangs 
(sleeps) once the target
    is done. (i.e. no other targets are built).
Stefan Seefeld
Departement de Physique
Universite de Montreal
email: address@hidden


      ...ich hab' noch einen Koffer in Berlin...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]