[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: a question about make

From: Paul Smith
Subject: Re: a question about make
Date: Tue, 31 Jul 2007 09:26:58 -0400

On Tue, 2007-07-31 at 14:03 +0800, suyi wrote:
> After  I uncompress  make.3.81.tar on IBM AIX 5.3 ,I run make then
> get  the error
> exec(): 0509-036 Cannot load program ./make because of the following errors:
>         0509-150   Dependent module /usr/local/lib/libintl.a(libintl.so.3) 
> could not be loaded.
>         0509-152   Member libintl.so.3 is not found in archive

It looks to me like you obtained a pre-built version of GNU make for AIX
from somewhere, and it doesn't work on your version of AIX.  Probably it
was built for a newer version of AIX than yours (usually software built
for older versions will work on newer versions, but often software built
for newer versions won't work on older versions).

Sorry, but we cannot help you: the FSF doesn't provide pre-built
binaries of its software (unless you purchase a binary CD from them) and
we can't debug problems with them.  You'll have to contact the folks who
built that binary and ask them for help.

Alternatively, you can go to ftp://ftp.gnu.org/pub/make/ and download
the source and build your own copy: if you have a C compiler it's pretty
straightforward.  See the README and INSTALL files.

Good luck!

 Paul D. Smith <address@hidden>          Find some GNU make tips at:
 http://www.gnu.org                      http://make.paulandlesley.org
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist

reply via email to

[Prev in Thread] Current Thread [Next in Thread]