[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Checking software build tries for “commands.cmo”

From: Philip Guenther
Subject: Re: Checking software build tries for “commands.cmo”
Date: Wed, 14 Jun 2017 14:08:38 -0700
User-agent: Alpine 2.21 (BSO 202 2017-01-01)

On Tue, 13 Jun 2017, SF Markus Elfring wrote:
> I am testing the following pattern rules with the program “GNU Make 4.2.1-1.7”
> on my openSUSE Tumbleweed system as I would like to adjust some areas
> in affected make scripts for another evolving software tool.
> %.cmi: %.mli
>       $(OCAMLC_CMD) -c $<
> %.cmo: %.ml %.cmi
>       $(OCAMLC_CMD) -c $<
> %.cmx: %.ml %.cmi
>       $(OCAMLOPT_CMD) -c $<
> I have tried a specific command out.
> address@hidden:~/Projekte/Coccinelle/20160205/commons> LANG=C make -d 
> common.cmo V=1 
> This test showed the expected results.

Two questions:
1) What files were present in the directory before you ran that command?
2) What _was_ that expected result?

(I would guess that most of the people on the bug-make mailing list have 
never worked with ocaml and therefore don't know what needs to be done to 
build it.)

> I have tried another command variant out.
> address@hidden:~/Projekte/Coccinelle/20160205/commons> LANG=C make -d 
> commands.cmo V=1
> Now I wonder why I do not get the desired software generation results for
> this test case. Why is the source file “commands.ml” not compiled again
> in the way as the other one?

The snippet of Makefile you provided didn't include any rules for building 
"commands.ml", so I don't understand why you expect make to build it.

Philip Guenther

reply via email to

[Prev in Thread] Current Thread [Next in Thread]