[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: unresolved symbols with ncurses-5.6 on Alpha OSF1 5.1A

From: Martin MOKREJŠ
Subject: Re: unresolved symbols with ncurses-5.6 on Alpha OSF1 5.1A
Date: Wed, 25 Apr 2007 20:24:01 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20070221 SeaMonkey/1.1.1

Thomas Dickey wrote:
On Tue, 17 Apr 2007, Martin MOKREJŠ wrote:

So, my problem is that static libs are being built on my system, but linker is instructed to use shared libs.

It's been a while since I encountered _that_. The workaround (not implemented in ncurses) is to add linker directives (which of course depend on the system and compiler) such as -static and -dynamic before/after the -lncurses

$ gcc ../objects/tic.o ../objects/dump_entry.o -L../lib -static -lncurses 
-dynamic -I../progs -I. -DHAVE_CONFIG_H -I. -I../include  -D_OSF_SOURCE 
-DNDEBUG -I/usr/home3/mmokrejs/include/ncurses -O2 -o tic
You are right, that works, but still imagine I would have static and dynamic
libs site-wide installed and that the generated Makefile does not force
the build process to use specifically the newly generated library in source

Why isn't generated something like

$ gcc ../objects/tic.o ../objects/dump_entry.o ../lib/libncurses.a -I../progs 
-I/usr/home3/mmokrejs/include/ncurses -O2 -o tic

The build process knows that static libs were generated, it knows they are in 
and also their name ...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]