[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Invisible form fields w/ ncurses-5.7 on Fedora

From: Thomas Dickey
Subject: Re: Invisible form fields w/ ncurses-5.7 on Fedora
Date: Fri, 12 Aug 2011 18:42:10 -0400 (EDT)

On Fri, 12 Aug 2011, Grant Edwards wrote:

I'm sure it's something I'm doing wrong in my application, but I can't
figure out what it might be.

I've got an app that's worked fine for 10 years, but a customer using
Fedora Linux reports that starting about a year ago the form fields
disappeared (other text written on the same panel is there, but the
form's data fields are invisible).  I'm actually not sure whether the
form fields are invisible, inactive, or completely absent.  The cursor
doesn't seem to navigate between fields, so it could be that the
fields are completely missing or inactive.

I reproduced the problem on Fedora 14[1] using gnome terminal 2.32.0
and ncurses 5.7.  Changing the gnome terminal's foreground/background
colors didn't help.

The same application built on Gentoo with ncurses 5.7 works fine with
gnome terminal 2.32.1 (and about a half-dozen other terminals with
various foreground/background settings).

What could I be doing wrong that would have caused form fields to go
invisible/missing on Fedora but not other distros?

Offhand - I've done occasional bug-fixes for forms, but as usual most of the attention's on the base ncurses library. "5.7" could (in most distributions) be any development snapshot between 5.7 release and 5.8 release (5.9 recommended...). As I recall it, most of the distributions are exercising various configure options that I've provided, not making patches to the code. Knowing the patch level is a good start.

I have virtual machines for Fedora 14 and 15 (which I usually use via ssh to run uxterm...). Gentoo's too much involvement, iirc. So I might be able to reproduce the problem. The cause of the problem might be visible in an ncurses trace for instance, but tracing generally isn't configured in the distributions.

The "cursor doesn't navigate" comment doesn't seem to reflect on
whether it's gnome-terminal (which has a number of display defects
in every release) or some other terminal type.  If the cursor's not
being hidden, you should be able to see it move around.  But you seem
to be commenting on the problem reproducing only in gnome-terminal.

So... is it possible for me to test your application (or is that not feasible for whatever reason)?

A quick way to check it without direct access to the application would be to run the application in "script", capturing the typescript. I can test the typescript by playing it back, to see what's on the screen - and how the cursor moves around in your test. (There's a copy of slowcat in my
ftp area for ncurses - basically the typescript could be replayed on a
comparable terminal with the same screensize).

[1] I initially tried to duplicate the problem using Fedora 15 but
   found the new desktop to be so unusable I gave up.  There's
   probably a way to install Fedora 15 w/ LXDE or XFCE, but I know
   the customer reporting the problem is running Gnome.

Sadly, the worst desktop that I've heard of recently won't run in the
virtual machine that I set aside for it.  It's preventing me from
viewing some interesting bugs ;-)

Thomas E. Dickey

reply via email to

[Prev in Thread] Current Thread [Next in Thread]