[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

INFOPATH not working

From: Fred Ma
Subject: INFOPATH not working
Date: Fri, 16 Apr 2004 01:25:16 -0400

> Subject: infopath lossage
> Date: Thu, 15 Apr 2004 13:09:41 -0400
> From: address@hidden (Karl Berry)
> To: address@hidden
> Paul Eggert told me about the troubles you were having with info finding
> entries in your dir directory.  I tried to read all the posts on the
> subject, but I'm not sure I have the whole picture.
> Could you send address@hidden the dir file that's getting read, and
> the command line invocation?  Then I can see if I can reproduce it.
> I doubt this is a problem for your sysadmin.  Hopefully we'll be able to
> diagnose it so that eventually he can just apply a patch and rebuild.
> You could just also build it in your own directory for testing purposes :).


I was advised to send some information here.  I'll summarize the
problem so far (thread "INFOPATH not working" in comp.unix.programmer
and comp.unix.solaris).  Our sys admin recently installed info in
/opt/info.  Typing "info -f /opt/texinfo/info/texinfo" works, but
typing "info texinfo" hangs the xterm session for about 20 seconds.
Then I get the message:

   info: dir: No such file or directory

I did

   PROMPT> export INFOPATH=/opt/texinfo/info/

but this didn't help.

In the past, I experience such hanging when I had a path in $PATH that
was a soft link to a network directory.  The link existed, but the
target did not.  I confirmed that this was also the case here.  These
are the troubleshooting steps I took, with help from newsgroup
respondents.  I am running on sparc solaris 8.

   PROMPT> truss -d info texinfo  2>&1 | tee truss.out

      Base time stamp:  1081840201.9938  [ Tue Apr 13 03:10:01 EDT 2004 ]
       0.0000 execve("/opt/texinfo/bin/info", 0xFFBEE9AC, 0xFFBEE9B8)  argc = 2
       0.0331 mmap(0x00000000, 8192, PROT_READ|PROT_WRITE|PROT_EXEC, 
       0.0550 resolvepath("/usr/lib/ld.so.1", "/usr/lib/ld.so.1", 1023) = 16
       0.0692 open("/var/ld/ld.config", O_RDONLY)             Err#2 ENOENT


       0.2558 ioctl(1, TCGETA, 0xFFBEE8B4)                    Err#22 EINVAL
       0.2576 brk(0x000469B8)                                 = 0
       0.2580 brk(0x000489B8)                                 = 0
       0.2593 stat("/opt/texinfo/info/dir.info", 0xFFBEE450)  Err#2 ENOENT
       0.2599 stat("/opt/texinfo/info/dir.info.gz", 0xFFBEE450) Err#2 ENOENT


       0.2754 stat("/usr/local/info/dir-info.Z", 0xFFBEE450)  Err#2 ENOENT
       0.2761 stat("/usr/local/info/dir-info.Y", 0xFFBEE450)  Err#2 ENOENT
      stat("/usr/local/info/dir/index", 0xFFBEE450) (sleeping...)               
      30.3076 stat("/usr/local/info/dir/index", 0xFFBEE450)   Err#2 ENOENT
      30.3106 stat("/usr/local/info/dir/index.gz", 0xFFBEE450) Err#2 ENOENT


      30.5359 stat("/usr/local/info/dir.z", 0xFFBEE558)       Err#2 ENOENT
      30.5383 stat("/usr/local/info/dir.Z", 0xFFBEE558)       Err#2 ENOENT
      30.5402 stat("/usr/local/info/dir.Y", 0xFFBEE558)       Err#2 ENOENT
      30.5487 stat("dir", 0xFFBEE6C8)                         Err#2 ENOENT
      info30.5503     write(2, " i n f o", 4)                         = 4
      : 30.5515       write(2, " :  ", 2)                             = 2
      dir: No such file or directory30.5522   write(2, " d i r :   N o   s u c 
h".., 30)      = 30

      30.5527 write(2, "\n", 1)                               = 1
      30.5533 llseek(0, 0, SEEK_CUR)                          = 402687
      30.5535 _exit(1)

I highlighted the line that says "sleeping", which happens when it
searches /usr/local/info/dir/index.  The following confirms that dir
links to a nonexistent target.

   PRMOPT> cd /usr/local/info ; ls -ld dir

      lrwxrwxrwx  <..SNIP..>  Sep 28  2001 dir -> 

   PROMPT> ls dir


Here, "@" means it's a link, as per "ls -Fp".  Now I check the target:

   PROMPT> ls dir/*

      dir/*: No such file or directory

Most of the other truss lines give ENOENT, which means that the
file/directory doesn't exist.  I manually checked each path and
confirmed that they don't exist.  I tried using "info -d" to specify
the location of the info files, but that didn't prevent info from
looking in the offending "dir":

   PROMPT> ls /opt/texinfo/info

      info-stnd.info    texinfo           texinfo-13        texinfo-5
      info-stnd.info-1  texinfo-1         texinfo-14        texinfo-6
      info-stnd.info-2  texinfo-10        texinfo-2         texinfo-7
      info-stnd.info-3  texinfo-11        texinfo-3         texinfo-8
      info.info         texinfo-12        texinfo-4         texinfo-9

   PROMPT> inf -f /opt/texinfo/info/info.info

      < WORKS OK >

   PROMPT> info -d /opt/texinfo/info info

      info: dir: No such file or directory

If I press "?" inside info to get the help menu, I am also told:

   The current search path is:

An "ls -ld" for each directory shows that none of them exist.  No
delay or anything, and no dir in any of those directories.  I thought
these directories should be overridden by INFOPATH or "info -d".

Thanks for anything you can do.  At this point, I am reluctant to bug
the sys admin about rebuilding info because I'm still waiting for him
to follow through with some pretty needy things.  Also, my thesis
proposal date is literally about to pounce on me, so any build
attempts of my own will be deferred until afterward.  If the fix is
something simple like setting an environmental variable, that would
the be best case [that's optimisim :) ].


Fred Ma
Dept. of Electronics, Carleton University
1125 Colonel By Drive, Ottawa, Ontario
Canada, K1S 5B6

reply via email to

[Prev in Thread] Current Thread [Next in Thread]