[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cygwin: texi2dvi stumbles over texinfo.tex

From: Christopher Faylor
Subject: Re: Cygwin: texi2dvi stumbles over texinfo.tex
Date: Sat, 27 May 2006 13:04:51 -0400
User-agent: Mutt/1.5.11

On Sat, May 27, 2006 at 10:05:20AM +0200, Ralf Wildenhues wrote:
>Hi Karl, Christopher,
>* Karl Berry wrote on Sat, May 27, 2006 at 01:21:16AM CEST:
>> [Excluding cygwin, I doubt they care about this part.]
>Oh yes they will care especially about this part.  ;-)
>>     $ texindex ./main.au ./main.cp ./main.pg ./main.sb
>>     Segmentation fault (core dumped)
>> Regrettably, with both the texindex in the released 4.8, and the
>> texindex from current CVS, I get no seg fault on GNU/Linux (x86).
>That's because the bug isn't in GNU texinfo-4.8, but in the Cygwin
>package texinfo-4.8-2.
>* Christopher Faylor wrote on Fri, May 26, 2006 at 07:28:13AM CEST:
>> That's apparently a call to mktemp, although I can't tell what's causing
>> the problem.
>> Setting the CYGWIN environment variable to error_start:gdb might help
>> with finding what the argument to mktemp is.
>Thanks for those hints.  It turns out to be mktemp.
>Running under gdb (or with CYGWIN set accordingly) doesn't help much if
>you don't have source and debugging symbols are not compiled in.  So I
>learned that Cygwin allows to install source packages, rebuilt
>texinfo-4.8-2, and also built the pristine texinfo-4.8 from gnu.org.
>The latter worked fine, the former crashes.  The diff between both is
>shown at the end of this message.

Thanks very much for looking into it.  I released a new version of
texinfo last night.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]