[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Images inside @quotation are not indented in PDF (but are in HTML)

From: Karl Berry
Subject: Re: Images inside @quotation are not indented in PDF (but are in HTML)
Date: Mon, 31 Mar 2008 13:08:15 -0500

    If I have a @quotation block containing an image, the pdf generated by 
    texi2pdf does not put any indentation on the image, 

I've made the following change to texinfo.tex (and updated CVS,
ftp://tug.org/tex/texinfo.tex, etc.) to try to fix this.
At least your test document (thanks) seems to be ok, now.
Improves the dvi output too, not that you care :).

    Is this a bug in texi2pdf and is there a workaround?

The workaround would be to put @noindent before the @image in the source.


--- texinfo.tex.~1.263.~        2008-03-17 10:49:03.000000000 -0700
+++ texinfo.tex 2008-03-31 10:52:37.000000000 -0700
@@ -7439,3 +7442,3 @@ end
-    \nobreak\bigskip
+    \nobreak\medskip
     % Usually we'll have text after the image which will insert
@@ -7445,5 +7448,9 @@ end
-    \line\bgroup
+  % Leave vertical mode so that indentation from an enclosing
+  % environment such as @quotation is respected.  On the other hand, if
+  % it's at the top level, we don't want the normal paragraph indentation.
+  \noindent
+  %
   % Output the image.
@@ -7458,3 +7465,3 @@ end
-  \ifimagevmode \egroup \bigbreak \fi  % space after the image
+  \ifimagevmode \medbreak \fi  % space after the standalone image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]