[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-wget] Compilation Failed..

From: Micah Cowan
Subject: Re: [Bug-wget] Compilation Failed..
Date: Mon, 20 Apr 2009 10:29:26 -0700
User-agent: Thunderbird (X11/20090318)

Hash: SHA1

Taichi Matsumoto wrote:
> Hi,
> I tried to make 1.12-dev with ubuntu 8.04, gcc 4.2.4
> and my operation is following
>  # hg clone http://hg.addictivecode.org/wget/mainline wget
>  # cd wget
>  # ./autogen.sh
>  # ./configure
>  # make
> But I got following error messages.
> ---Error message on ubuntu
> ubuntu# make
> Making all in lib
> make[1]: Entering directory `/tmp/wget/lib'
> make  all-am
> make[2]: Entering directory `/tmp/wget/lib'
> make[2]: Nothing to be done for `all-am'.
> make[2]: Leaving directory `/tmp/wget/lib'
> make[1]: Leaving directory `/tmp/wget/lib'
> Making all in src
> make[1]: Entering directory `/tmp/wget/src'
> make  all-am
> make[2]: Entering directory `/tmp/wget/src'
> /bin/bash ../ylwrap css.l .c css.c -- :
> make[2]: *** [css.c] Error 1
> make[2]: Leaving directory `/tmp/wget/src'
> make[1]: *** [all] Error 2
> make[1]: Leaving directory `/tmp/wget/src'
> make: *** [all-recursive] エラー 1
> ---

For this, my guess would be that you don't have lex/flex installed. Try
"sudo apt-get install flex"

> And I tried same operation with osx 10.5.6 and gcc 4.0.1.
> and got other error messages.
> --- Error Messages on osx
> mymac% make
> Making all in lib
> make  all-am
> make[2]: Nothing to be done for `all-am'.
> Making all in src
> make  all-am
> gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/usr/local/etc/wgetrc\"
> -DLOCALEDIR=\"/usr/local/share/locale\" -I.  -I../lib    -g -O2 -MT
> version.o -MD -MP -MF .deps/version.Tpo -c -o version.o version.c
> version.c:4: error: syntax error before '-' token
> make[2]: *** [version.o] Error 1
> make[1]: *** [all] Error 2
> make: *** [all-recursive] Error 1
> ---

This is probably a result of our unportable use of "echo", which someone
submitted a simple patch for, but I never got around to fixing. I'll get
that done.

The error messages in config.log were red herrings, btw: you should
expect compilation errors to occur there. They're how the configure
script detects what settings to use. If you don't see the configure
script itself give you errors directly, you're good to go.

- --
Micah J. Cowan
Programmer, musician, typesetting enthusiast, gamer.
Maintainer of GNU Wget and GNU Teseq
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


reply via email to

[Prev in Thread] Current Thread [Next in Thread]