[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug-wget] some quirks in current code

From: Daniel Stenberg
Subject: [Bug-wget] some quirks in current code
Date: Thu, 10 Jun 2010 09:10:16 +0200 (CEST)
User-agent: Alpine 2.00 (DEB 1167 2008-08-23)


I've pulled the sources from the bzr repo and I've built wget from source on my reasonably updated debian unstable dev machine. Here's a summary of the initial problems I fell over:

1. I didn't have 'autopoint' installed so ./bootstrap failed with an unhelpful
   error. It should rather check for autopoint to be present and tell me that
   I need it.

2. configure.ac:51: option `dist-lzma' not recognized
   This seems to rely on a rather recent automake version as I have automake
   1.9.6 here and get that error. I just removed 'dist-lzma' from the
   AM_INIT_AUTOMAKE() macro in configure.ac and things could continue.
   (automake 1.10 has been broken on Solaris for so long that I've just never
   managed to upgrade to that without getting hit in the face and downgraded
   again so I will remain using 1.9.x for the forseeable future.)

3. These fixed, I now got a configure script that I ran. Then I invoke 'make'
   (inside the source dir tree) and then my build ends with an error like

if gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/usr/local/etc/wgetrc\" -DLOCALEDIR=\"/usr/local/share/locale\" -I. -I. -I. -I../lib -I../lib -O2 -Wall -MT exits.o -MD -MP -MF ".deps/exits.Tpo" -c -o exits.o exits.c; \ then mv -f ".deps/exits.Tpo" ".deps/exits.Po"; else rm -f ".deps/exits.Tpo"; exit 1; fi
if test -n ""; then cp "./build_info.c.in" .; fi
/usr/bin/perl "../build-aux/build_info.pl" \
Cannot open /build_info.c.in: No such file or directory at ../build-aux/build_info.pl line 39.
make[3]: *** [build_info.c] Error 2
make[3]: Leaving directory `/home/daniel/src/wget/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/daniel/src/wget/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/daniel/src/wget'
make: *** [all] Error 2

   This problem is because the src/Makefile.am uses a 'abs_builddir' variable
   that in my case is not set (blank). I could fix this by doing this:

=== modified file 'src/Makefile.am'
--- src/Makefile.am     2010-05-27 11:59:46 +0000
+++ src/Makefile.am     2010-06-10 07:03:35 +0000
@@ -63,7 +63,7 @@
 build_info.c: $(srcdir)/Makefile.am $(srcdir)/build_info.c.in
        if test -n "$(VPATH)"; then cp "$(srcdir)/build_info.c.in" .; fi
        $(PERL) "$(top_srcdir)/build-aux/build_info.pl" \
-           "$(abs_builddir)/build_info.c"
+           "$(top_builddir)/src/build_info.c"
        if test -n "$(VPATH)"; then rm -f build_info.c.in; fi

 ESCAPEQUOTE = sed -e 's/[\\"]/\\&/g' -e 's/\\"/"/' -e 's/\\";$$/";/'

4. Now if I run ./wrc/wget -V it says:

  Currently maintained by Micah Cowan <address@hidden>.

  ... which I believe isn't true and I believe you want a patch similar to

=== modified file 'src/main.c'
--- src/main.c  2010-05-31 07:45:03 +0000
+++ src/main.c  2010-06-10 07:06:32 +0000
@@ -853,7 +853,7 @@
      names such as this one. See en_US.po for reference. */
   fputs (_("\nOriginally written by Hrvoje Niksic <address@hidden>.\n"),
-  fputs (_("Currently maintained by Micah Cowan <address@hidden>.\n"),
+  fputs (_("Currently maintained by Giuseppe Scrivano <address@hidden>.\n"),
   fputs (_("Please send bug reports and questions to <address@hidden>.\n"),



 / daniel.haxx.se

reply via email to

[Prev in Thread] Current Thread [Next in Thread]