bug-zebra
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Routing tables in zebra and FreeBSD kernel


From:
Subject: Routing tables in zebra and FreeBSD kernel
Date: Wed, 6 Mar 2002 10:56:57 +0200

OS - FreeBSD 4.5-stable (02-march-2002) 

Zebra - CVSed at 4-march-2002
Configuration options is  --disable-ipv6 --prefix=/usr/local  
--sysconfdir=/usr/local/etc/zebra 

Sarted daemons - zebrad & ospfd
----------------- start of zebra.conf ---------------------
!                                                                               
! Zebra configuration saved from vty                                            
!   2002/02/27 09:37:23                                                         
!                                                                               
hostname nas-01:zebra                                                           
password *******                                                               
enable password *******                                                        
!                                                                               
interface ed0                                                                   
!                                                                               
interface lp0                                                                   
!                                                                               
interface faith0                                                                
!                                                                               
interface lo0                                                                   
!                                                                               
interface tun0                                                                  
!                                                                               
interface tun1                                                                  
!                                                                               
interface tun2                                                                  
!                                                                               
interface tun3                                                                  
!                                                                               
interface tun4                                                                  

............. description of all 32 tun interfaces

!                     
interface tun31                                                                 
!                                                                               
interface gif0                                                                  
!                                                                               
interface gif1                                                                  
!                                                                               
interface gif2                                                                  
!                                                                               
interface gif3                                                                  
!                                                                               
ip route 0.0.0.0/0 193.108.248.1                                                
!                                                                               
line vty                                                                        
!                                
------------------------- end of zebra.conf ----------------------
------------------------- start of ospfd.conf  --------------------
!                                                                               
! Zebra configuration saved from vty                                            
!   2002/03/04 14:38:55                                                         
!                                                                               
hostname nas-01:ospfd                                                           
password *********                                                              
 
enable password ********                                                        
!                                                                               
!                                                                               
!                                                                               
interface ed0                                                                   
 ip ospf network non-broadcast                                                  
!                                                                               
interface lp0                                                                   
 ip ospf network point-to-point                                                 
!                                                                               
interface faith0                                                                
!                                                                               
interface lo0                                                                   
!                                                                               
interface tun0                                                                  
 ip ospf network point-to-point                                                 
!                                                                               
interface tun1                                                                  
 ip ospf network point-to-point                                                 
!                                                                               
interface tun2                                                                  
 ip ospf network point-to-point                                                 
!                                                                               
interface tun3                                                                  
 ip ospf network point-to-point        

............. description of all 32 tun interfaces

!                                                                               
interface tun30                                                                 
 ip ospf network point-to-point                                                 
!                                                                               
interface tun31                                                                 
 ip ospf network point-to-point                                                 
!                                                                               
router ospf                                                                     
 ospf router-id 193.108.248.10                                                  
 redistribute connected route-map STATICIP                                      
 network 193.108.248.0/27 area 0                                                
 area 0 export-list MEGASTYLE                                                   
 area 0 import-list MEGASTYLE                                                   
 neighbor 193.108.248.1 priority 1                                              
 neighbor 193.108.248.11 priority 2                                             
 neighbor 193.108.248.14 priority 2                                             
 neighbor 193.108.248.17 priority 2                                             
!                                                                               
access-list MEGASTYLE permit 193.108.248.0/22                                   
access-list STATICIP permit 193.108.249.128/25                                  
!                                                                               
route-map STATICIP permit 10                                                    
 match ip address STATICIP                                                      
!                                                                               
line vty                                                                        
!                            
--------------------------- end of ospfd.conf----------------------

This is snapshot of 2 tables: zebra and KRT 

nas-01:zebra> sh ip rou conn
Codes: K - kernel route, C - connected, S - static, R - RIP, O - OSPF,
       B - BGP, > - selected route, * - FIB route

C>* 127.0.0.0/8 is directly connected, lo0
C>* 193.108.248.0/27 is directly connected, ed0
C>* 193.108.249.2/32 is directly connected, tun2
C * 193.108.249.3/32 is directly connected, tun0
C>* 193.108.249.3/32 is directly connected, tun10
C>* 193.108.249.4/32 is directly connected, tun14
C>* 193.108.249.5/32 is directly connected, tun4
C>* 193.108.249.8/32 is directly connected, tun3
C>* 193.108.249.10/32 is directly connected, tun7
C>* 193.108.249.11/32 is directly connected, tun12
C>* 193.108.249.14/32 is directly connected, tun5
C>* 193.108.249.16/32 is directly connected, tun8
C>* 193.108.249.20/32 is directly connected, tun13
C>* 193.108.249.21/32 is directly connected, tun11
C>* 193.108.249.22/32 is directly connected, tun9
C>* 193.108.249.23/32 is directly connected, tun6
C>* 193.108.249.137/32 is directly connected, tun1

nas-01# netstat -nr | grep tun
193.108.249.1      193.108.248.10     UH          1     8348   tun1             
## absent in zebra table
193.108.249.3      193.108.248.10     UH          0      554   tun0
193.108.249.4      193.108.248.10     UH          0        0   tun3             
    ## zebra table points to tun14 
193.108.249.5      193.108.248.10     UH          0      293   tun4
193.108.249.7      193.108.248.10     UH          0     4137   tun9             
## absent in zebra table
193.108.249.8      193.108.248.10     UH          0      446   tun7             
 ## zebra table points to tun3 
193.108.249.9      193.108.248.10     UH          0     5958   tun8             
## absent in zebra table
193.108.249.10     193.108.248.10     UH          0        1   tun2             
  ## zebra table points to tun7 
193.108.249.12     193.108.248.10     UH          0        0  tun10             
 ## absent in zebra table 
193.108.249.14     193.108.248.10     UH          0    19376   tun5
193.108.249.16     193.108.248.10     UH          0      950   tun6             
## zebra table points to tun8   
193.108.249.20     193.108.248.10     UH          0   130118  tun13
193.108.249.137    193.108.248.10     UH          0    52092  tun11        ## 
zebra table points to tun1 

Due to this differents neiborghs can't get a _real_ information about routing. 

WBR, Vadim



reply via email to

[Prev in Thread] Current Thread [Next in Thread]