[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] BB + FLU not working

From: felix winkelmann
Subject: Re: [Chicken-users] BB + FLU not working
Date: Wed, 13 Apr 2005 22:08:31 +0200

On 4/12/05, Matt Gushee <address@hidden> wrote:
> Hello, all--
> Let me preface this by saying that I am totally new to Chicken, and in
> fact to Scheme--though I have some FP experience, having worked with
> OCaml for a couple of years, and have done a little with a couple of
> LISPish languages in the past. I have tentatively chosen Chicken for an
> application I want to develop because it compiles fast standalone
> executables, apparently works on Win32 without heroic measures, and has
> the kinds of libraries I need--one of them being bb.
> Now, after compiling and installing Chicken 1.89, I have installed bb on
> two Linux boxes. Both machines are running an up-to-date Arch Linux
> system, which means:
>    glibc-2.3.4
>    gcc-3.4.3
>    fltk-1.1.6
> However, one machine has FLU installed, and the other one doesn't. Since
> there is no Arch package for FLU, I downloaded and compiled the most
> recent version (2.14?).
> On the FLUless machine, bb seems to be working fine. At, least I have
> tried a couple of toy programs, both in the interpreter and compiled,
> and they worked as expected. On the machine with FLU, I get the following:
> #;1> (require-extension bb)
> ; loading /opt/chicken/lib/chicken/ ...
> Error: (load) unable to load compiled module
> "/opt/chicken/lib/chicken/"
> "/usr/local/lib/ undefined symbol: _ZN9Fl_Widget6resizeEiiii"
> The only things that occur to me are that maybe this version of FLU
> isn't supported (which versions are known to work?), or perhaps having
> Fltk installed under /usr and FLU under /usr/local doesn't work. But
> those are just guesses.
> Any clues will be greatly appreciated.

It seems you have an old version of FLTK. This is what my machine shows:

% nm /usr/local/lib/ | grep resize
         U _ZN11Fl_Browser_6resizeEiiii
00033d80 T _ZN11Flu_Spinner6resizeEiiii
0001c2a0 T _ZN13Flu_Combo_Box6resizeEiiii
0003e910 T _ZN14Flu_Wrap_Group6resizeEiiii
0001abc0 T _ZN15Flu_Chat_Buffer6resizeEiiii
         U _ZN16Fl_Double_Window6resizeEiiii
000263e0 T _ZN16Flu_File_Chooser11FileColumns6resizeEiiii
00028440 T _ZN16Flu_File_Chooser6resizeEiiii
000371d0 T _ZN16Flu_Tree_Browser6resizeEiiii
0001b580 T _ZN21Flu_Collapsable_Group6resizeEiiii
         U _ZN7Fl_Tile6resizeEiiii
         U _ZN8Fl_Group6resizeEiiii
         U _ZN9Fl_Input_6resizeEiiii
         U _ZN9Fl_Widget6resizeEiiii              <--- looks for this in libfltk
% fltk-config --version
% nm /usr/local/lib/ |grep "resize"
0006c730 T _Z10resizeformv
00030d40 T _ZN11Fl_Browser_6resizeEiiii
00046f90 T _ZN12Fl_Help_View6resizeEiiii
00064d40 T _ZN14Fl_Value_Input6resizeEiiii
0005d7b0 T _ZN15Fl_Text_Display6resizeEiiii
00039660 T _ZN16Fl_Double_Window6resizeEiiii
0004f8b0 T _ZN17Fl_Overlay_Window6resizeEiiii
00063530 T _ZN7Fl_Tile6resizeEiiii
0003fae0 T _ZN8Fl_Group6resizeEiiii
0004b380 T _ZN9Fl_Input_6resizeEiiii
00055880 T _ZN9Fl_Scroll6resizeEiiii
00065be0 T _ZN9Fl_Widget13damage_resizeEiiii
00065bb0 T _ZN9Fl_Widget6resizeEiiii                     <---- here it is
0006ab60 T _ZN9Fl_Window6resizeEiiii
00081aac b resize_bug_fix

If you execute the last nm+grep on your machine, does it list the missing


reply via email to

[Prev in Thread] Current Thread [Next in Thread]