[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] New user; egg problems

From: Mario Domenech Goulart
Subject: Re: [Chicken-users] New user; egg problems
Date: 07 Dec 2006 16:15:32 -0200
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.4

Hello Ivan,

On Thu, 07 Dec 2006 13:04:57 -0500 Ivan Raikov <address@hidden> wrote:

>    I think even the most simple kind of Chicken/egg versioning would
> go a long way.  For example, I can build easyffi and use it in Chicken
> 2.3 if I simply remove the -G option. So if chicken-setup supported
> different build commands for different versions of Chicken, this would
> make packaging Chicken code a whole lot easier. In my case, I want to
> provide my software as Debian packages, and so I am stuck with
> whatever version of Chicken is available in the current Debian stable
> release.

Would it be difficult to make Debian a little more up-to-date
regarding to Chicken?  2.3 is quite old.

Or maybe we should have an "unofficial" Chicken build for Debian and
its derivatives ([K,X]Ubuntu, Knoppix etc).  I don't know about dpkg
packaging and compatibility among distributions .deb packages, so I
have no idea if it's feasible, easy or even worth.

Best wishes,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]