[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] Problem installing easyffi/silex on cygwin

From: felix winkelmann
Subject: Re: [Chicken-users] Problem installing easyffi/silex on cygwin
Date: Mon, 16 Apr 2007 09:02:09 +0200

On 4/15/07, DrTheo Radish-Rho <address@hidden> wrote:
Hi all,

I'm trying to install easyffi on chicken scheme. My platform is cygwin

I have a problem with silex. When I run "chicken-setup easyffi", silex is
first downloaded and the installation begins. However, I end up with a huge
number of undefined symbols in silex.
I tried to manually install silex first as well by doing "chicken-setup
silex", but I get the same problem.
The error messages look something like this
silex.c:1: warning: -fPIC ignored for target (all code is position
silex.o:silex.c:(.text+0x2b): undefined reference to
silex.o:silex.c:(.text+0x5f): undefined reference to
silex.o:silex.c:(.text+0x55377): undefined reference to
collect2: ld returned 1 exit status

chicken -version gives "2.6 - windows-cygwin-x86 - [ ptables applyhook ]"

Does compilation work for other files ok? (i.e. does a simple application
and/or a dynamically loadable file (csc option -s) compile + link)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]