[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] Error compiling on AMD64 linux machine]

From: Richard Hollos
Subject: Re: [Chicken-users] Error compiling on AMD64 linux machine]
Date: Fri, 24 Sep 2010 10:42:52 -0600
User-agent: Mutt/1.5.9i

----- from Christian Kellermann <address@hidden> -----
>* Richard Hollos <address@hidden> [100923 23:24]:
>> We concluded that we needed a bootstrap compiler. It wasn't clear from 
>> reading
>> the README that I needed one. I got the impression that it was only needed
>> when compiling a development version.

>Which tarball did you install from initially? All release tarballs
>(4.X.0 versions) do include such a bootstrap compiler. The other
>tarballs 4.x.y with y != 0 are developer tarballs that assume you
>already have a chicken compiler running. What docs did you come
>across when choosing your download tarball? I am asking because
>that's where we might need better guidance for newcomers like you.
>Thanks for keeping at it and welcome to the chicken community!


The tarball I used was:

>From the main Chicken page, under the Download heading, I clicked:

Then I downloaded via the first link on the page: "4.6.0"

Two other things I tried which I didn't mention:

*After getting the error:
 "Error: (require) cannot load core library: chicken-ffi-syntax"
 I uninstalled with:
 make PLATFORM=linux uninstall
 Then removed the entire directory that was made by the tarball:
 Then unpacked the tarball again in /usr/local/src
 and tried an install again with:
 make PLATFORM=linux PREFIX=/usr/local
 and as root:
 make PLATFORM=linux PREFIX=/usr/local install
 This produced the same error.

*I have access to another machine which has identical hardware and operating
 system (AMD64, openSUSE 11.1) which also, like mine, has never had Chicken
 installed on it. Unpacking the tarball chicken-4.6.0.tar.gz in /usr/local/src
 and trying an install with:
 make PLATFORM=linux
 then as root:
 make PLATFORM=linux install
 this time without PREFIX specified, I got the same error:
 "Error: (require) cannot load core library: chicken-ffi-syntax"

After this, I thought there was something quarky about OpenSUSE that was
causing the error. But it finally dawned on us to get a bootstrap compiler as
described in my last post, and that worked.

Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]