[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Chicken-users] Difficulty installing Hyde egg

From: Felix
Subject: Re: [Chicken-users] Difficulty installing Hyde egg
Date: Tue, 05 Apr 2011 11:50:48 +0200 (CEST)

> This needn't be `chicken-install -init ~/tmp/foo/lib/chicken/5` ?

No, I tried it exactly as shown above.

> I guess I was thrown off by the above linked thread which stated:
>     ~/chicken/lib/chicken/5
>     You must also use this longer path for initialization via -init

I'm not sure. There might be bugfixes. Sorry, I know this is all
a bit messy.

>>   export CHICKEN_REPOSITORY=/home/felix/tmp/foo
>>   chicken-install hyde
> This doesn't need to be `chicken-install -p /home/felix/tmp/foo hyde` ?

No, just as given above. I tried it a few hours ago and worked ok
(with the exception of a failed hyde build, but for other reasons...)

> I tried your suggested sequence, things got stuck at the point of:
>     rm -fr /var/lib/chicken/5/
>     cp -r /var/lib/chicken/5/
>     cp: cannot create regular file `/var/lib/chicken/5/':
>     Permission denied

Is this with CHICKEN_REPOSITORY set?

> Then I did:
>     # chown -R john:john /var/lib/chicken/5
> And now things get stuck at:
>     cp: cannot create regular file `/usr/bin/scss2css': Permission denied
>     Error: shell command failed with nonzero exit status 256:
>     cp -r scss2css /usr/bin/scss2css

Executables get not installed in the repository, but in the BINPATH, where
"chicken", "csi", etc. are installed.

>> Can you perhaps try a newer chicken version?
> I'm running Debian Linux, so I guess that'd be
> chicken-boot-4.6.1-linux-x86.bz2
> as per ?

This is only for bootstrapping from the git repository sources when
you have no previous chicken installed.

> Might try that when I have more time...was hoping to be able
> to stick with using the Debian package and make that work.

I have no solution for the BINPATH problem. Another option would
be to build a chicken from a recent release or snapshot tarball
and install it in your HOME (or somewhere else, where you have
full access rights) and use that instead.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]