[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [cp-patches] simplifying windows checks

From: Michael Koch
Subject: Re: [cp-patches] simplifying windows checks
Date: Thu, 12 Aug 2004 07:06:37 +0200
User-agent: KMail/1.6.2

Am Donnerstag, 12. August 2004 04:53 schrieb Dalibor Topic:
> Hi all,
> the attached patch replaces all the instances of checks whether we
> are running on Windows with a simple private static final boolean
> variable test. I hope it makes the code clearer and more readable.
> changelog:
> 2004-08-12  Dalibor Topic  <address@hidden>
>       * java/io/File (ON_WINDOWS): New constant.
>       Use ON_WINDOWS instead of checking separatorChar.

I think its most common to add fields on to of the class in classpath 
and libgcj. I think this field is better suited in the VMFile class 
and should be called "isWin32" or similar.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]