[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[cp-patches] Re: simplifying windows checks

From: Michael Koch
Subject: [cp-patches] Re: simplifying windows checks
Date: Thu, 12 Aug 2004 09:11:37 +0200
User-agent: KMail/1.6.2

Am Donnerstag, 12. August 2004 09:04 schrieb Jeroen Frijters:
> Dalibor Topic wrote:
> > the attached patch replaces all the instances of checks
> > whether we are running on Windows with a simple private
> > static final boolean variable test. I hope it makes the
> > code clearer and more readable.
> This is a good idea, but like Michael, I think the field should be
> in VMFile.
> Michael Koch wrote:
> > I think its most common to add fields on to of the class in
> > classpath and libgcj. I think this field is better suited in the
> > VMFile class and should be called "isWin32" or similar.
> Please don't call it Win32, the rules are the same on Win64.

Or "isWindows" ?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]