[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [cp-patches] simplifying windows checks

From: Dalibor Topic
Subject: Re: [cp-patches] simplifying windows checks
Date: Mon, 16 Aug 2004 00:05:20 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040413 Debian/1.6-5

Tom Tromey wrote:
"Michael" == Michael Koch <address@hidden> writes:

Use ON_WINDOWS instead of checking separatorChar.

Michael> I think its most common to add fields on to of the class in classpath Michael> and libgcj. I think this field is better suited in the VMFile class Michael> and should be called "isWin32" or similar.

Actually, I think all caps is fine, on account of it being a constant.

OK, I'll try to recap the discsussion:

patch is OK in general, but it should be moved to VMFile as VMFile.ON_WINDOWS. Right?

if so, I can proved an updated patch next week.

dalibor topic

reply via email to

[Prev in Thread] Current Thread [Next in Thread]