[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

classpath 0.10 and GCJ Version 3.3.3 20040215

From: Steven Augart
Subject: classpath 0.10 and GCJ Version 3.3.3 20040215
Date: Tue, 20 Jul 2004 17:27:48 -0400

I just accidentally tried to build Classpath 0.10 using GCJ (I was
using an AIX machine, and I'd left Jikes out of my path).  The GCJ
version is:

        gcj (GCC) 3.3.3 20040215 (release)

This gave the error:

     /usr/gnu/bin/gcj --bootclasspath '' --classpath 
-C -d . @classes
../../classpath-0.10/java/security/cert/ error: Class 
`' can't subclass interface 
   public abstract class X509Certificate extends Certificate implements 

The "configure" script currently tests whether GCJ, if used, has at
least version 3.3.  This doesn't seem to be adequate to get around
the error.

Does anybody know what version of gcj we need to avoid this
complaint?  We should update the configure script appropriately.


--Steve Augart

Steven Augart

Jikes RVM, a free, open source, Virtual Machine:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]