[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Removing the TARGET_* layer or not ?

From: Dalibor Topic
Subject: Re: Removing the TARGET_* layer or not ?
Date: Mon, 09 Aug 2004 12:21:16 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040413 Debian/1.6-5

Andrew Haley wrote:
Mark Wielaard writes:
> > On Wed, 2004-08-04 at 10:27, Andrew Haley wrote:
 > > I guess as long as we're stuck with C90 we can't use inline.
 > > Am I right in thinking that GNU Classpath targets C90?
> > Yes. More accurately would probably be that we try to support platforms
 > that still depend on gcc-2.95. This is not that uncommon.

Really?  Not uncommon that platforms still depend on 2.95?  Are these
platforms that have been orphande due to lack of maintainers, or some
other reason?

Current stable *BSD releases use gcc2. NetBSD is switching to 3.3.1 for 2.0. FreeBSD 5.3 may end up with gcc 3.3.3. OpenBSD 3.5 uses 2.95.3 for some arches, 3.3.2 on others.

I assume that gcc2 will be history in a year or two ;)

dalibor topic

reply via email to

[Prev in Thread] Current Thread [Next in Thread]