[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: can Mauve help me test a PersonalJava implementation?

From: Steven Schwarz
Subject: Re: can Mauve help me test a PersonalJava implementation?
Date: Fri, 29 Apr 2005 09:34:02 -0700 (PDT)

On 29-Apr-2005 Archie Cobbs wrote:
> Steven Schwarz wrote:
>> Thanks for the suggestion to make jars -- that will definitely help
>> make things more convenient, if I can get around something else.
>> Here's the something else:
>> If I compile with a JDK 1.4.2 or 1.5.0 I end up with class files with
>> major.minor version 46.0.  If I attempt to run them with a
>> PersonalJava or JDK 1.1.8 VM, I run up against the limitation that
>> those VMs are only empowered to accept classes whose versions are in
>> the range 45.0 .. 45.65535, i.e. strictly before version 46.0.  JDKs
>> 1.2.2 and 1.3.1 will produce class files with versions before 46.0,
>> but unfortunately, cannot compile Mauve, as I explained in my previous
>> posting.
>> So I guess my question about whether I can use Mauve in the
>> environment I need to is made equivalent to whether I can find a
>> compiler that will compile Mauve producing classes with version
>> strictly before 46.0.  Any suggestions for such a compiler?  I've only
>> ever used Sun (or blackdown) JDKs.  Will Jikes help?
> Just compile with "-target 1.4" (or whatever).
> -Archie
> __________________________________________________________________________
> Archie Cobbs      *        CTO, Awarix        *

reply via email to

[Prev in Thread] Current Thread [Next in Thread]