[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Files full of zeros with coreutils-8.11 and xfs (FIEMAP related?)

From: Eric Sandeen
Subject: Re: Files full of zeros with coreutils-8.11 and xfs (FIEMAP related?)
Date: Thu, 14 Apr 2011 10:56:16 -0500
User-agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv: Gecko/20110303 Thunderbird/3.1.9

On 4/14/11 10:52 AM, Pádraig Brady wrote:
> On 14/04/11 16:50, Eric Sandeen wrote:
>> On 4/14/11 9:59 AM, Pádraig Brady wrote:
>>> On 14/04/11 15:02, Markus Trippelsdorf wrote:
>>>>>> Hi Pádraig,
>>>>>> here you go:
>>>>>> + filefrag -v unwritten.withdata                                         
>>>>>> Filesystem type is: ef53                                                 
>>>>>> File size of unwritten.withdata is 5120 (2 blocks, blocksize 4096)       
>>>>>>  ext logical physical expected length flags                              
>>>>>>    0       0   274432            2560 unwritten,eof                      
>>>>>> unwritten.withdata: 1 extent found
>>>>>> Please notice that this also happens with ext4 on the same kernel. 
>>>>>> Btrfs is fine.
>>>> `filefrag -vs` fixes the issue on both xfs and ext4.
>>> So in summary, currently on (2.6.39-rc3), the following
>>> will (usually?) report a single unwritten extent,
>>> on both ext4 and xfs
>>>   fallocate -l 10MiB -n k
>>>   dd count=10 if=/dev/urandom conv=notrunc iflag=fullblock of=k
>>>   filefrag -v k # grep for an extent without unwritten || fail
>> right, that's what I see too in testing.
>> But would the coreutils install have done a preallocation of the destination 
>> file?
>> Otherwise this looks like a different bug...
>>> This particular issue has been discussed so far at:
>>> Note there it was stated there that ext4 had this
>>> fixed as of 2.6.39-rc1, so maybe there is something lurking?
>> ext4 got a fix, but not xfs, I guess.  My poor brain can't remember, I think 
>> I started looking into it, but it's clearly still broken.
>> Still, I don't know for sure what happened to Markus - did something 
>> preallocate, in his case?
> Well that preallocate test is failing for him
> when the source file is either on ext4 or xfs.
> He noticed the issue initially on XFS when copying
> none preallocated files, so XFS probably just has
> the general issue of needing a sync before fiemap,
> where as EXT4 just has this preallocate one
> (though I've not seen it myself).
> cheers,
> Pádraig.

well, if I simply take the preallocation step out of the testcase, it works 
fine on xfs without a sync.

So I still don't know what Markus hit...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]