[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[DejaGnu] tcl autoloader broken by runtest?

From: Charles Bergan
Subject: [DejaGnu] tcl autoloader broken by runtest?
Date: Fri, 25 Jan 2002 19:05:57 -0800

I saw only one reference to autoloader problems with dejagnu from a google
search and no answers, please forgive me if this is on an FAQ I couldn't

I've got a 7.1 linux box with tcl/tk8.3.4, Expect5.3.4, Dejagnu 1.4.2

uname -a gives me: Linux alphaomega 2.4.2-2 #1 Sun Apr 8 20:41:30 EDT 2001
i686 unknown

If I create a directory called test, and place in that directory a file
called unknown.exp with the single line:
"package require none"

(My config/unix.exp is empty.)

when I run: runtest --tool=test
I get:

WARNING: Couldn't find tool init file
Test Run By cbergan on Fri Jan 25 18:51:35 2002
Native configuration is i686-pc-linux

                === test tests ===

Schedule of variations:

Running target unix
Using /usr/share/dejagnu/baseboards/unix.exp as board description file for
Using /usr/share/dejagnu/config/unix.exp as generic interface file for
Using ./config/unix.exp as tool-and-target-specific interface file.
Running ./test/unknown.exp ...
ERROR: (DejaGnu) proc "tclPkgUnknown none {}" does not exist.
The error code is 

                === test Summary ===

When I run "expect test/unknown.exp", I get what I expect:

can't find package none
    while executing
"package require none
    (file "test/unknown.exp" line 1) 

It seems that runtest.exp (or my configuration) has somehow broken the tcl
autoloader.  tclPkgUnknown is 
the package that implements unknown(), the function that is called to
attempt autoloading.  I think tcl should have called "unknown none" rather
than the package.

I actually saw this problem trying to use a tcl proc that was in a purchased
tcl binary libary, but was able to come up with this simpler example that
fails in the same way.

Any ideas?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]